PM1115UW doesn't hold WiFi settings

I want to connect a printer to the USB port and have it accessible on my existing WiFi, so I'm trying to configure it for Infrastructure WiFi and join it to my existing SSID but when it reboots, it's back in Ad-Hoc mode.

This is my second device as StarTec support said since the first one wouldn't hold the configuration, it must be a dud, so I replaced it. However the second device is acting the same so I'm thinking this is user error. I don't use Mac or Windows so need to configure this without the software. It seems like it is very possible to do this via the web interface. I set my laptop to a compatible IP address and can open the configuration page.

I click Setup and on the System page set a unique username and password, then save & restart. I reconnect, click Setup then Wireless and find my SSID in the list. When I click it, the page auto-fills with the correct info. I enter my Network Security key and click Save & Restart:

After restarting, I go to Status then view the Wireless tab and it shows that it's in Ad-Hoc mode again:

What am I missing? Is there another step to make the settings stick?

Answers

  • LukasT
    LukasT StarTech.com Employee

    Hello @stylishhumdrum

    Thank you for taking the time to post on the StarTech.com Community!

    From what you have described, you are going through the correct steps for connecting the PM1115UW to a WiFi network.

    I would suggest manually typing in the SSID rather than selecting it from the list at the bottom of the Wireless configuration page, as

    If that does not resolve the issue, I see in your screenshot that the SSID you are trying to connect to has some asterisks in it, would you be able to try connecting it to a SSID that only has alphanumeric characters (0 to 9 or A to Z)?

    Next I would recommend trying a different browser application, or even another computer if you have one available you could use.

    I hope that this information is able to be of help to you and look forward to your reply!

    Lukas T

  • Thanks for responding, Lukas. I did try again by entering all data by hand instead of letting it populate. I also found the instructions in the "PM1115UW(EU/GB) Setup Guide":

    are a little different, in that they say to set a static IP address first, before adjusting the WiFi settings, so I did that - I set the printserver's IP address to match my wifi's network, saved those settings, reconnected via LAN by the new address, and am back where I started. It still does not retain the WiFi settings selected under the Setup -> Wireless tab.

    BTW, my SSID has asterisks in it because I masked it for the screenshot. It uses valid characters.

    Are you able to replicate this on another PM1115UW by chance? If so, does it work when you click the radio-button associated with your SSID, or do you need to manually enter it?

    I just received a third PM1115UW (I was optimistic that this would work) so can test this again. I'm not sure what using a different browser/computer would do. I don't have another one with a LAN jack.

  • It doesn't appear to be possible to save settings without a restart. This is problematic if trying to set the network to pick up a DHCP address after joining the WiFi network. How would this be accomplished when the settings revert when clicking the next tab?

  • LukasT
    LukasT StarTech.com Employee
    edited December 2022

    Hello @stylishhumdrum

    Thank you for the clarification on the SSID.

    We have successfully entered the SSID information by clicking the radio button from the list on the configuration page then scrolling back up and entering the network security information, however I wanted to see if entering in the SSID information manually would have a different result in your case.

    You are correct that in order for the settings to be saved, the unit does have to be rebooted by clicking the Save and Restart button at the bottom of the configuration pages before you change to a different setup page.

    It is strange for this many units to experience the same issue. May I ask the model of the router broadcasting the SSID to see if we might have had any previous reports of issues? 

    Our next best troubleshooting step would be to test connecting the PM1115UW to a different router and SSID to see if connecting to a different device experiences the same problem, would you be able to test this?

    Lukas T

  • I'm using Aruba InstantOn AP22 access points. I have another that I could bring up for a test, but I find it unlikely to make a difference. Do you have a known-working SSID I can use with it?

    Just in case it doesn't like the current SSID, here's a step-by-step while trying to connect to a new one I just created called "mytest":

    Scanned for the network, clicked the appropriate radio-button to select the new SSID, entered the Network Security key (I changed nothing else - all fields auto-populated):

    Scrolled down and clicked Save & Restart:

    Saw this during the restart:

    After restart the home page loads:

    Click Wireless tab to see if it kept the settings or not:

    As you can see, after clicking Save and Restart the wifi settings were lost and it was back in Ad-Hoc mode again.

  • LukasT
    LukasT StarTech.com Employee

    Hi @stylishhumdrum

    We would normally expect the print server to be able to connect to any SSID with alphanumeric characters, like the "mytest" SSID you created.

    When there have been multiple units experiencing the same issue and the setup steps are being followed correctly, as you have been doing, we like to changing out external factors to the product itself to see if those may be having any effect.

    The reason I recommend testing a different access point or router is because it seems that this access point has been a constant factor so far, so we want to try changing this variable. 

    We want to try a different model of access point if possible in case there may be something with the Aruba InstantOn AP22 you have been trying so far that is preventing the print server from being able to connect to the network which could be causing it to return to the Ad-hoc settings when it cannot establish a connection. The results of this change can help us determine what next steps we may have.

    Lukas T

  • The third model took the settings and is working as expected:

    All three devices were purchased from StarTech Store. The third device was purchased at a lower price and has a date code of 2016 and uses a 5V-2A power supply, while the first two duds I tried were newer and had 5V-1A power supplies.

    This is the working model:

    And these are the previous two models I had purchased:

    Date codes. Working model on top:

    Model numbers are identical, FCC & IC numbers differ. Working model on right:

    Older, working model's ASIN is B00MZERNXQ, the firmware version from the working printserver is: 9.08.50E 0012 (2015/09/24 21:46:58).

    The non-working ASIN is ‎B00M77UME8 and is running firmware 9.08.57E 0017 (2021/03/22 19:32:43)

    Is the old firmware available for download so I can attempt to fix my newer device with it?

    Thank you!

  • LukasT
    LukasT StarTech.com Employee

    Hi @stylishhumdrum

    Thank you for the detailed information as well as the pictures comparing the unit that could connect and the one that cannot.

    We will need to look into this further and I will follow up with you as soon as I can.

    Lukas T

  • LukasT
    LukasT StarTech.com Employee

    Hello @stylishhumdrum ,

    Thank you for your patience as we looked into this.

    We have not had any other reports of firmware 9.08.57E 0017 not being able to connect to a wifi network and going back to the Ad-hoc settings like you are experiencing.

    We do not have firmware version 9.08.50E 0012 available that is on the unit connecting to your network unfortunately, the earliest that we have available is 9.08.57E 0015. I have attached a zip file with this version that you can try.

    We recommend running the latest version of the firmware for PM1115UW as it includes bugfixes and improvements. However, it can be beneficial to run older firmware versions such as this one for the purposes of troubleshooting or for deployments with specific needs.

    Lukas T