PEXUSB3S42V 4 port USB3 PCIe card - not working

I have purchased the above card and it shows in the device manager as a hub I have an ASUS Z170 motherboard with a Intel64_Family_6_Model_94_-_Intel(R)_Core(TM)[email protected]_4.00GHz

I have attached an image of what is shown under USB in device manager

when I plug a drive in to the StarTech PEXUSB3S42V 4 port USB3 PCIe card - nothing

I have tried different PCIe slots to no avail, Any Ideas please?


  • AthaT
    AthaT Employee

    Hello @gillas. We appreciate you taking the time to post on our Community forum!

    We are sorry to hear that you experienced difficulty with our PEXUSB3S42V. We recommend ensuring that the latest BIOS, and chipset drivers are installed on the computer. Furthermore, have you tried any other USB devices apart from the external hard drive? For further assistance we have opened case # (484-1228493) and encourage you to contact us at [email protected] Please include the case number and 'community post support' in the subject line.

    Thank you in advance, and we look forward to hearing from you!

    Atha T