S351BU313 Win 10 not seeing

I have a 6TB Western Digital drive properly seated in a S351BU313. I turn it on and Win 10 does its ding-a-ling. saying something has been activated. The drive spins up. I cannot find it in file explorer or disk management. I’m about to switch to a new DELL Win 11 Optiplex tower as a Peer to Peer file server. The mate to this drive is internal and is recognized by Win 10. I’ve tried an unformatted different drive. I’ve tried an SDOCK2U313. All to same result. Win 10 seems to see something attached but cannot identify it. Both external devices and drive used to work. I suspect the kind folks at Microsoft have made my life easier with one of their updates, but I don’t know.

Hi there @jebcpa!

Thanks for reaching out for some help. I’ll see what I can do to help out. To start, I’d love to ask some clarifying questions just so I’ve got a full understanding of what’s going on. I hope that’s fine.

  1. What is the exact model of this WD 6TB drive?
  2. What is this drive out of? If it’s from a computer, is it a failed/failing computer?
  3. If you connect this drive directly via SATA to one of your computers, does it show up correctly or still have issues?

Ideally, when connecting the S351BU313 or the SDOCK2U313 and there’s a drive in it that’s not an SSD you should feel it spin up to show the drive is getting power. From there, I’d check device manager to make sure nothing is giving an error, such as the USB connection from either enclosure. You can access Device Manager via pressing the Windows Key + X key and selecting Device Manager from the list. Anything with an error should show with a yellow triangle, containing an exclamation point inside it.

If there is anything errored out there, disconnect the drive enclosure you’re testing with and see if it goes away. If it does, you might have something going on with the cable, so you could try testing a replacement cable. Let me know how this goes!

Hi JustinW

  1. [WD Black 6TB Performance Desktop Hard Disk Drive - 7200 RPM SATA 6 Gb/s 128MB Cache 3.5 Inch - WD6002FZWX] Western Digital.

  2. Purchased new from Amazon

  3. Cannot connect to SATA. No active slots available. Will try to plug in to a Win 11 machine. No change.

No errors in device manager. Does not show up in file explorer or disk management.

When I goto Eject Media I see “Eject USB 3.1 Device” (on Win 11)

Thanks for your help


I have an older SAT3510BU2V. Plugged that into my Win 11 machine. It is recognized. Seems to work properly. Note: Different Disk. 1TB “WDC WD 10 EZEX-

Hi Jim,

Are you able to feel the drive spinning up? When you say the drive is from Amazon, that’s as a brand new unused drive yes?

This should work fine. I own this same drive I know it worked in my SDOCK2U313 but it’s been some time, and that was on an older build of Windows 10. That said, it’s quite rare that support is removed. I know the SDOCK2U313 is not what this post is about, but you mentioned you had the same issues with it in testing, which is why I mentioned it. Additionally, it’s odd that you’ve had issues with other drives as well.

I’ve got some other stuff I’d like to run by you and if possible, I’d love to hop on a remote support session so I can connect over and take a look at what your system is seeing. Do you mind e-mailing support@startech.com referencing CAS-70988 in the subject line? We can go through some more troubleshooting there and post the results here once we sort things out in the event someone ends up with the same issue in the future.

I put 6TB drive into SAT3510BU2V. Again, Windows 11 Ding-A-Ling, BUT NOT recognized by Win 11 or Disk Management.

I just put the 1TB drive into the S351BU313. and Win 11 sees it. Could my 6TB Drive be trash?


If it’s a brand new drive, not purchased used, this is pretty unlikely however it’s not impossible. Defect rates for electronics are usually well under 1% but they are never 0%, so on occasion, a brand new piece of electronics can make it through production and to a customer but be dead on arrival. I’d love to go through some further discussion to double-check and see if you will need to go through an RMA with Amazon, and perhaps help arm you with information such that you can use it in the RMA request with them. Do you mind e-mailing in at this point? I may want to hop on the phone with you and we don’t want you putting your number out publicly of course.

It’s not DOA. It was in use but has not been for more than a year. It was new and unused when I purchased it. Hard to believe it would just die, but . . .

Further correction. Drive is " Western Digital 6TB WD Black Performance Internal Hard Drive - 7200 RPM Class, SATA 6 Gb/s, 256 MB Cache, 3.5" - WD6003FZBX

That drive should be fine as well. Do you mind e-mailing in at this point? I may want to hop on the phone with you and we don’t want you putting your number out publicly of course. If you’re not comfortable, please let me know.

I did email,. I will again.

Perfect, I might’ve missed it before, my apologies. I’ll make sure to take care of it today when I get a chance and arrange for some things tomorrow or Wednesday.

As an update to this thread, through testing, there are indications of issues with the drive in question. Some testing was suggested, but a return was chosen given the time investment.

Should you be reading this post and see similar issues, do test a direct SATA connection to a computer if possible, and test another known working drive. If that fails, the please reach out to our support!