Startech 10 port powered usb-c hub

My 10 port usb-c 10 gbps hub just one year old 5022010521worked fine for a year but now it just stopped. I disconnected everything and when I plug in again the green light lits up for less than 30 seconds, then it stops and nothing works. I didn’t have time to check if something works within this short period of time. I tried disconnecting, restarting my pc but it still doesn’t work. Hope you’ll have an answer to this failure.


Hello @DonaldMarlisa and thank you for your interest in our Community.

I am sorry to hear about the issues you are experiencing with our 10 port hub. I would recommend you to make sure to disconnect all USB devices from the hub and then remove power for at least 60 seconds. Once done, please start by testing one single USB device (such as a keyboard or a mouse) and testing it on a different USB port of your computer. If this doesn’t work, would you have another computer you could test the hub on?

Thank you in advance and we look forward to hearing back from you!

Emmanuel B.