USB stops working after shutdown due to inactivity

The only way I have discovered so far to recover USB inputs is to disconnect all power inputs, i.e. USB connectors and the DC power adapter, slow count to 10, then reconnect everything.

Does anyone know a way to prevent this, or an easier recovery method? I have tried using a mouse jiggler but even that does eventually allow one of the computers to shut down due to inactivity and I’m back to the rigmarole described above.

By the way I am using an SV211KDVI with 25 pin DVI-D cables (since neither my monitor or computers support the 29 pin DVI-I connectors)

Hello @pjonez ,

Thank you for your question about the USB troubles with the SV211KDVI.

It sounds like you are performing a sort of power cycle with the SV211KDVI after your computers are automatically shutting down or going to sleep. This sort of power cycle is very useful with many different KVMs. Often we will recommend waiting a bit longer but it sounds like 10 seconds is enough time for this particular KVM.


  1. The SV211KDVI will draw power from the USB ports on each computer. It may be good to verify that the power adapter included with the KVM is functioning correctly and is connected to a reliable power source. This can add stability to the function of the KVM.

    Ensure that the video function on the SV211KDVI continues to work correctly when the USB A to B cables are disconnected from both computers

  2. Try connecting the power supply to a different power source. If it is connected to a power bar try testing it on a wall plug.


Are you working with Windows systems? There may be other things that you can try.

USB Selective Suspend

If USB connectivity is lost we can recommend disabling USB selective suspend. Here are some instructions for that:

Why does my USB device stop working after my computer wakes back up from sleep mode in Windows? - IT Pro Community

USB Power Management

  1. If you have administrative permissions on your computers go to the device manager.

    You may want to connect a USB device that can easily be recognized in the device manager to the SV211KDVI hub ports. In Each computer find and select that USB device. Then you can check the USB device and each device in the connection tree back to the USB controller to see if you can disable the USB Power Management in the properties for each entry.

    To find the connection tree:

    Open the device manager

  2. In Windows 10 you can right-click on the start menu and select the 6th entry from the top
  3. Find and select your USB device
  4. In the Device Manager menu bar select: View > Devices by connection. This will rearrange the device manager list in a tree view by connection
  5. by_connection.png

    You can now view each hub and device between the SV211KDVI and the USB controller. Check the properties of each entry in that tree for any Power Management features and disable each.

    This may be helpful if this is some sort of power issue.


    Regarding the DVI connections, we do not expect there to be any issues using DVI-D cables with the SV211KDVI.


    If these options do not help you may want to look into other power plan settings for each computer. There may be settings that will help you achieve more reliable connectivity.

    Let us know if this helps or get back to us with some more specific details about your equipment, and what you are trying to achieve and we can definitely dig a bit deeper for you.

    David F

Thank you for your response. Your suggestion of disabling USB selective suspend seems to have solved the problem, but I will give it a few days to be sure. I had tried disabling hibernation on my new Windows 11 PC that is the main problem (since the old Windows 7 computer is in almost constant use), but that would defeat the logic of using hibernation to save energy and the environment.

I will hopefully report back in a few days time that the problem has been solved :slight_smile:

Hey @pjonez,

Thank you for your reply!

I am happy to hear about the initial positive results after disabling USB Selective Suspend.

Hopefully, that resolved things; we are here to help if anything changes. ?

We look forward to hearing back from you.

Disabling USB selective suspend has not completely solved my problem, so I am trying your other suggestion of disabling all Power Management settings in Device Manager for all the USB devices in use - I have only found these settings in place for my keyboard and mouse, so fingers crossed :slight_smile: