Displays lose signal during active use - MacBook Pro M3

I am using a MacBook Pro M3 laptop with Sonoma 14.5 and the StarTech USB dock in clamshell mode and have 2 4K ASUS monitors connected. Most times, the dock works great. However, recently, the displays will lose signal and cycle to black, show no HDMI signal and the reacquire the signal and come back on. Total cycle time is about 40 seconds if I initiate keyboard or mouse clicks after the signal is lost. This is not the screen timing out because it usually happens during a new session at random times for about 20 minutes and my screen saver is set to 3 hours.

Any thoughts on further diagnosis or what might be happening? This is extremely annoying when I am on a call, especially if I am presenting.


Hello @debbie,

Thank you for posting on the Startech.com Community.

I am sorry to hear you are having an issue with the displays you have connected to our docking station. To help determine what troubleshooting steps to take, can I please ask for the following information:

  • What is the Product ID of the specific Startech.com docking station you are using? You should be able to find this on the bottom of the dock and it may start with DK, USB, or TB for example.
  • What are the specific models of the Asus monitors that are connected to the dock?

I look forward to your reply!

Lukas T

The StarTech dock is DK31C3HDPD. The ASUS monitors are both ASUS PB277Q 27" QHD, 75Hz, 1ms, HDMI, DVI, VGA. I have the resolution set at 3840 x 2160.

Everything was working fine until about the past month.

Hello @debbie,

Thank you for confirming this information.

Can I clarify which ports on the dock these monitors are connected to, Video 1, 2, or 3? If you move one of the Asus monitors to the port that does not have one connected, does it experience the same issue?

I would recommend uninstalling the DisplayLink software used by our dock and reinstalling the latest version to see if that provides an improvement. To uninstall, you will need to open Finder, navigate to your Applications then drag DisplayLink Manager to the trash.

The latest version of the DisplayLink software can be found on the product page here by clicking the Drivers & Downloads tab: Hybrid USB-C USB-A Dock - Triple 4K 60Hz - USB-C Docking Stations | Universal Laptop Docking Stations | StarTech.com
You will want to download the option named “[displaylink] mac usb display adapter.zip”. A PDF with instructions for installing can be found in the sub-folder named “OS 12.x, 13.x, 14.x”

Please let us know your results.

Lukas T

I had the monitors plugged into Video 2 and 3 to the HDMI port. When I moved one of them to Video 1, that monitor remained black, even though it was recognized by my Mac and only had a max resolution of 1920 X 1080.

I tried several other combinations, but was only able to get both displays to come on together using Video 2/3.

I upgraded to the correct driver, but now can’t get DisplayLink to start. Still diagnosing, just wanted to give you an update.

The software in the OS 10.14 folder did not contain the display manager software. I had to install the Display Manager from the OS 10.15 folder to get it working again. At this point, everything appears to be working, and I am cautiously optimistic that this will solve my problem. I will let you know if the issue presents itself again.

Thank you!

Hello @debbie,

I am glad to hear that reinstalling the drivers has solved the issue! Please do let us know if the issue does start again.

Lukas T